Como puedo solucionar el error incompatibilidad de versiones